
2. 高周波デバイスの設計とシミュ

レーション 

1. 電磁波の数値シミュレーション 

1.1. はじめに 

偏微分方程式の数値シミュレーションにはいく

つかの方法があり、様々なソフトウェアが存在す

るが、電磁波という古典的な計算でも、ソフトウ

ェアによって大きな食い違いが生じる事がある。

その際に、偏微分方程式の数値解法の特性を知っ

ていれば、問題解決の糸口になるかもしれない。 
 なお電磁波シミュレーションと合わせた荷電

粒子シミュレーションまで記述したかったが、専

門的になってしまうので別の機会にする事にし

て、今回は省いた。 

1.2. 有限要素法(FEM) 

有限要素法はメッシュの形状が自由に選べるた

め、境界条件に適合しやすく、さらに次数を上げ

れば精度が出易い方法である。 
 公開されている、もしくは商用のソフトウェア

としては軸対称ではSuperfish、３次元ではHFSS
など非常に精度の高いプログラムがあり、従来の

マイクロ波設計では欠かせないシミュレーショ

ン方法となっていた。しかし境界に適合したメッ

シュを生成するという事は、荷電粒子との相互作

用を計算する上では、どのメッシュの中に粒子が

存在するのかを判定するのに多くの計算時間を

要するため、電磁波計算だけなら良いが、荷電粒

子を組み込むと、あまり良い方法とは言えない。 
 電磁波の固有モードを計算する Superfish の場

合も、荷電粒子のトラッキングを行う Parmera
に電磁界分布を渡す際には、補間して直交格子に

変換している。従ってここでは有限要素法の基礎

を説明するにとどまる事とする。 

1.2.1. Galerkin FEM 

領域S内の２次元のヘルムホルツ方程式の厳密解

を u とする。その境界 C1 上でu u= 、Ｃ２上で

の法線方向の導関数が nn
uu u
n
∂

= =
∂

とする。これ

らに重さ関数 v を、両辺にかける。 
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この１項目はヘルムホルツ方程式の誤差に v をか

けた物の積分を表し、２項は境界での残差の積分

である。これを部分積分し、以下の式を得る。 
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ここで境界 C1 では 0v = なので、１項目は消え以

下になる。 
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この式は弱形式と呼ばれる。ここで v は境界 C1
上で 0 になる以外は任意なので、 v uδ= とする。 
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これは次のように変形できる。 
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従って 
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これは、汎関数 F に対して、δF=0 を解けば良い

事を意味し、Rayleigh-Ritz 法とも対応がついて

いる。 
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1.2.2. 電磁波の汎関数 

ここでは、電磁波の磁場の空間分布を示す式 

 2k∇×∇× =H H  (1-8) 

の汎関数を示す。電場についての式 

 2k∇×∇× =E E  (1-9) 

も同じである。 
 式(1-8)の汎関数は 
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  (1-10) 

である。ここで、H は磁場の空間分布である。ま

た、汎関数はエネルギーに関係していることが多

く、このようにすると磁場のエネルギーに関係し

た量になるのである。わざわざ、複素共役を使わ

ないで計算しても同じ結果が得られる。この場合

は、汎関数が複素数になる。 
 それでは、この式の第 1 変分がゼロになる条件

が式(1-8)を満足するかどうか調べる。第一変分

は、H を Hδ 変化させたときの微小変化量で 
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この式に発散定理を使い、

式を整理すると

  (1-11) 

となる。 
 いつものように、任意の Hδ に対して、この第

一変分 Fδ がゼロになる条件を考える。第 1 変分

Fδ は実数であるが、H や Hδ は複素数である。

この複素数の実数部と虚数部の変化に対して、第

1 変分がゼロとならなくてはならない。わかりや

すくするために、複素数になっている部分を 
 



 r ii= +H H H  (1-12) 

 r iiδ δ δ= +H H H  (1-13) 

と実数部と虚数部に分ける。これらを、式(1-11)に
代入すると、 
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となる。これが、実数部と虚数部に分けた汎関数

の第 1 変分である。もちろん、任意の Hδ に対し

て、これがゼロになる条件を考えるのである。任

意の Hδ と言うことは、任意の Hrδ と Hiδ に対し

て、第 1 変分がゼロになる条件を探すのである。 
そのためには、この式の右辺第 1 項と 2 項がと

もにゼロにならなくてはならない。右辺第 1 項は、

境界条件を表し、 
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の場合、ゼロとなる。通常は、( ) 0H∇× × =n と

する。これが自然境界条件で、ノイマン条件とな

る。この磁場の回転は、マクスウェル方程式より、

0H iωε∇ × = Eとなる。従って、ノイマン条件は、

E n× と書き直すことができる。すなわち、電場

と境界の法線方向が一致するのである。これは、

金属の境界条件である。すなわち、境界を指定し

なければ、自然に金属の境界条件が満足されるの

である。一方、 0δ =H はディレクイ条件で、境

界の値を指定した場合である。 
 第 2 項がゼロとなるのは、 
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となる必要がある。これは、マクスウェルの方程

式から導かれた磁場の偏微分方程式と同等であ

る。 
 以上のことから、高周波の電磁場の磁場を計算

するためには、式(1-10)の第一変分をゼロにすれ

ばよいことが分かる。静磁場のマクスウェルの方

程式は、式(1-10)の第 1 変分をゼロにするのと等

しいのである。 
 電場については、ここでは計算しないが、全く

同じ手順で求められる。そして、結果も全く同じ

である。 

1.2.3. 軸対称定在波問題 

軸対称空洞内部の電磁場を求めるための汎関数

を示す。問題は定在波に限るものとする。 
 軸対称問題は、円柱座標系を使うのがセオリー

である。この場合、空洞の形状は完全軸対称であ

る。定在波の場合、磁場は実数として取り扱うこ

とができる。式(1-10)では円柱座標系の回転の演

算が表れ、それは 
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である。 
 一般には、これを、汎関数の式(1-10)に代入す

ることになる。しかし、通常の空洞では最も共振

周波数の低いモードが重要になる。加速空洞の場

合、通常は最低次のTMモードが運転に使われる。

これが、運転モードとなり、真っ先に解析したい

モードである。このモードは、場がθ 方向の依存

性を持たず、磁場はHθのみである。このモード

の磁場の回転は、 
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となる。この回転の結果を汎関数の式(1-10)に適

用すると以下の式になる。 
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電場の計算 
有限要素法を用いて、式(1-19)の第 1 変分がゼロ

となるHθが、軸対称空洞の磁場になる。この磁

場から、電場を求めるためには、マクスウェル方

程式を使う。これを時間の微分の項を jω− に置き

換えると、 

 jω∇× = −H D  (1-20) 

となる。これから電場は 
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j
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と求められる。ここで、円柱座標系の回転を計算

することになる。それは、式(1-17)のとおりで、

ここではHθのみなので、先に示した式(1-18)のよ

うになる。従って、電場は以下のようになる。 
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1.3. 境界要素法 

境界要素法が非常に興味深いのは、計算格子を計

算空間内部に配置する必要が無く、表面のみに形

成すれば良いため、複雑な３次元ＣＡＤ形状にお

いて正確かつ、簡単に格子の形成が可能な事であ

る。境界要素法は、マクスウェル方程式の積分形

から出発する。スカラーヘルムホルツ方程式に帰

着できる場合は、通常の本に載っている解法で計

算が可能であるが、３次元の電磁波解析を行う場

合、ベクトルヘルムホルツ方程式の解法が必要で

ある。ベクトルヘルムホルツ方程式の積分形は、

結果の式は本や論文に書いてあるが、私の調べ方

が悪いのだと思うが、導出過程の書物が見つから

なかったので、私が導出した過程を１の付録に書

いておいた。付録の計算に従うと、結果として以

下のような式が得られる。 
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この式は既に、電界、磁界は表面のみに帰着でき

ているため、これを離散化すれば、行列が得られ、

表面の解が計算できる。離散化する際の注意点と

してはグリーン関数の体積積分は、表面上では立

体角になるため、左辺に係数Cがかかる事である。

またこの定数 C を単純に立体角とするより、ラプ

ラス方程式の基本解 lG を使って 

l

S

G
C dS

n

∂
= −

∂∫ として求めた方が積分の誤差

が吸収でき、精度が上がるようである。 
なお有限要素法と比較した場合の問題点は以

下の通りである。 



• 行列要素が複素数で、かつ密になり、有限要

素法のようなバンドマトリクスを効率良く

解く方法が使えない。ただ逆に行列が密なの

で開き直って高次の補間を使う事はできる。 

• 波数 k がグリーン関数に入っており、k に対

して行列が線形でないため、行列の固有値問

題に帰着できない。従って固有モードの計算

には det(M)=0 を k を変えて探索するしかな

く、膨大な時間がかかる。 

• ２次元ではグリーン関数がハンケル関数に

なり計算に非常に時間がかかる。 

• 軸対称問題を２次元問題に帰着できない。 
 
これらを打破する方法として多重極子展開法な

ど、近接するノードを一まとめにして、多重極子

展開する事で、計算を高速化し、かつ行列を帯状

にする試みがなされている。 

 

Fig. 1 境界要素法により計算した TM115モード 

 Fig. 1 は、境界要素法で円筒空洞の高次固有モ

ード(TM115)を計算した結果である。円筒部及び端

板部は高次のラグランジ補間を用いて離散化し

たため、少ないメモリ消費でこのような高次モー

ドを正確に解けた。しかし固有モードを求めるた

めには、det(M)=0 を探索するのに膨大な時間がか

かった。ただし、このような問題は伝搬解析では

起こらないので問題は無い。 

1.4. 差分法 

差分法と言えば昔は精度が悪いという印象があ

り、有限要素法や境界要素法が好まれてきた。し

かし、様々な精度向上の試みにより、有限要素法

等と同等な精度が得られるようになり、近年は計

算の単純な差分法も再び台頭するようになって

きた。 
 マクスウェル方程式を計算するための差分法

としては、FDTD 法や FIM 法、等価回路を用い

た TLM 法、微分を連続させた CIP 法などがある。

この中で最も単純な差分法は FDTD 法であるの

で、まずは FDTD 法について述べる。その後差分

法における精度向上ついて簡単に説明する。 

1.4.1. FDTD 法 

時間領域差分法とは、差分法を時間領域まで拡張

した数値計算方法である。この章では、まず一般

的な差分化について述べ、マクスウェル方程式を

空間領域における差分化を行う。その後、時間領

域における差分化を行い、空間、時間領域におけ

る差分化を行う。 
 
差分化 
2 次元の任意の座標位置（i、j）（但し i、j は整数）、

時間ステップ n における関数 F を 

 ( , ) ( , , )nF i j F i x j y n t= Δ Δ Δ  (1-26) 

と定義する。中央差分を用いて空間、時間の差分

化の式は次のように表される。 
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関数 F の F を電場 E あるいは磁場 H と考えると

電磁波について差分化することができる。 
 
空間領域における差分化 
２次元での 10TE モード時（ 0zE = ）のマクスウ

ェル方程式は 
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と表すことができる。この場合、それぞれの方程

式はFig. 2 を参考にすると２点間の中央差分に

よって表すことができる。すなわち、式(1-29)で
表させる xE (□印)は zH (×印)の中央差分によっ

て示され、式(1-30)で表させる yE (○印)は zH (×

印)の中央差分によって示され、さらに式(1-31)で
表させる zH (×印)は xE (□印)と yE (○印)のそれ

ぞれの中央差分で示されることがわかる。 
 このような一連の考えから、Fig. 2 の右図のよ

うな一つのセルを考える。ここで、座標に一般性

を持たせる為次式のように定義する。 
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Fig. 2 二次元問題における解析モデルとセル構成 

式(1-32)の定義を用いてマクスウェル方程式を空

間領域で差分化すると、 
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と表すことができる。 
 



時間領域における差分化 
時間領域における差分化のために次のように時

間の定義を行う。 

 ( )0
n
x xE E t t n t= = + Δ  (1-36) 

ここで、 
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Fig. 3 電界と磁界の時間の関係 

である。この定義を用いてマクスウェル方程式を

時間領域で差分化すると、 
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と表すことができる。この式の意味するところを

Fig. 3 を用いて説明をする。n 回目に計算された

電界 nE は一周期前の 1nE − とその半周期前の
1
2nH −
によって計算され、またそれに対応する磁

界
1
2nH +
は、 nE と 1nH − によって計算されること

を示している。 
 

空間、時間領域における差分化 
(1-27)、(1-28)で求めた結果を用いて、マクスウル

方程式の空間、時間領域における差分化（2 次元）

を行うと、 
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と表すことができる。今回は 2 次元で空間、時間

領域における差分化を行ったが、3 次元に拡張す

ることで実際の空洞共振器内でのマイクロ波シ

ミュレーションを行うことができる。 

1.4.2. 軸対称問題 

軸対称における rot は以下のようになっている。 
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これを書き直すと、以下のようになる。 
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従って、通常の２次元の rot の計算を軸対称にす

るには、通常のデカルト座標の rot で 

 x r

y

A A
A rAθ

=

=
 (1-44) 

として計算し、計算後に ,x zA A に 1/r し yA に r を

かければ計算できる。 

1.4.3. 差分法の精度向上 

従来差分法は有限要素法などに比べて、精度が劣

ると思われてきたが、これは境界上での物理値が

重要な流体などが対象だったからだと思われる。

マクスウェル方程式のように、波長より十分に小

さい形状の正確な差異が問題にならず、境界に適

合し、空間内部のみが正確に解ければ良いような

方程式の解法では、差分法でも精度向上が簡単に

可能である。 
精度向上に必要な事は、差分法に限らず、 

• 次数の向上 

• 境界適合 
である。次数の向上については、差分化の際に空

間差分の次数や時間差分の次数を上げれば良い

だけで、式が複雑になるだけなので、ここでは述

べない。 

境界適合については、例えば FDTD 法に対しては

Contour-Path 法が簡単であるので、境界適合の

例として、簡単に述べる。Fig. 4 は Contour-Path
法による導体への境界適合の概念図である。 
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Fig. 4 Contour-Path 法による境界適合 

マクスウェル方程式を表面積分し、導体上での接

線方向の電界の経路積分が０である事を利用す

ると、Fig. 4 に対応した式は以下のようになる。 
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このように単純な計算で、格子を境界に適合する

事なく、境界適合が可能である。 

2. 回路シミュレーションとエネルギー 

2.1. 等価回路シミュレーション 

等価回路シミュレーションの利点は、電磁波解析

では非常に時間がかかる結合空洞の周波数特性

や、何万波もの過渡解析が高速にできる事であ

る。結合空洞の回路シミュレーションをするため



には、それぞれの空洞の固有モードと、結合度が

必要になる。 

2.2.  周波数領域の計算 

Spice などの通常の回路シミュレーターで計算が

可能である。 

2.3. 過渡解析 

高周波空洞の過渡解析が必要なのは以下のよう

な場合である。 

• 進行波管などで分散特性を考慮したい場合 

• 入力 RF をフィードバックなどのため変調し

た場合の応答が知りたい場合 

• ビームローディングの過渡応答を考慮した

い場合 
 Spice などの通常の回路シミュレーターで、

LCR 回路を書けば簡単にシミュレーションでき

る。 
 しかし一般的な回路シミュレーターは連立微

分方程式を解くのに４次のルンゲクッタ法を用

いているため、高 Q の空洞の振動解の過渡シミュ

レーションには精度が足りない。高 Q 空洞の過渡

解析を行うには、以下の２つの方法がある。 
(1) 振動解を変数変換して取り除き、エンベロー

プのみを解く 
(2) 振動解をさらに高精度の微分方程式ソルバ

ーで解く。 
(1)の方がもちろん高速で賢い方法だが、最近は計

算機に汚染され、賢さでは先人には遠く及ばない

ので、私は汎用性もある(2)を勧める。 
(2)の場合、要は回路シミュレーターを製作すれば

良いわけだが、高精度の微分方程式ソルバーが必

要になる。Numerical Recipies によれば、有理関

数補外を利用したBulirsch-Stoer法が最も良い方

法だという事である。実際、Bulirsch-Stoer 法を

試してみた所 100万波程度の長時間の振動解の過

渡解析が安定にできる事が分かったので、この方

法を採用するのが良いと思う。 

3. モデルの作成とシミュレーションソフ

トの使い方 

3.1. ３次元データ形式 

電磁界解析や形状作成には現在は非常に多様多

種な物が存在し、クロスチェックも可能になっ

た。従来はこれらのツールを独立に使用してき

た。つまりそれぞれのシミュレーションソフトの

データ形式はあまり互換性が無く、それぞれ専用

の形式で記述して、図面は別に図面用のソフトウ

ェアで２次元の物を書いていた。 
 しかし近年 ACIS などの３次元干渉形状計算カ

ーネルの進歩により、いくつかのソフトウェアで

は共通のデータとして、例えば SAT/IGES/SHP
形式等のファイルが読み書きできるようになっ

ている。 
 ここでは我々が通常行っている３次元ＣＡＤ

である Autodesk 社の Inventor で３次元図面を

書き、それを Ansoft 社 HFSS や CST 社

MW-STUDIO へインポートしてシミュレーショ

ンする。計算が完了したら、元の３次元図面を２

次元図面にし加工会社、もしくは CAM 加工ので

きる加工会社へ直接３次元データを送付すると

いう流れで説明を行う事とした。こうする事で、

一貫性のある設計と、従来良くあった寸法ミスを

減らす事ができるという利点がある。しかし３次

元 CAD とシミュレーションソフトは連携して動

くわけではないので、シミュレーションソフトに

組み込まれた形状最適化機能などは使用できな

い。ただ、最適化は一般的には数点形状を変えて

計算すれば、簡単に行える事が多いので、あまり

問題にはならないだろう。 

3.2. Autodesk 社 Inventor の使い方 

(1) パーツを作成する 
①[ファイル]>[新規作成]の順にクリックする。 
 
②[新規ファイル ]ダイアログ  ボックスで、

Standard.ipt をダブルクリックする。 
 



③新しいパーツ ファイルを開くと、スケッチ モ
ードで作業できる。 

 
④スケッチは[2D スケッチパネル]を利用し、2 次

元でスケッチを行う。 
 
⑤スケッチが終わったら、右クリックをして[スケ

ッチを終了]を選択する。 
 
⑥スケッチを元に[パーツフューチャーパネル]を

用いて、押し出しや回転などを行い、3 次元の

パーツを作成する。 
 
⑦1 回のスケッチでできない場合にはさらに先ほ

ど書いた 3 次元の形状の面を右クリックし、新

しいスケッチを選択する。 
 
⑧④～⑥を繰り返してパーツを作る。 
 
⑨[ファイル]>[保存]から名前を付けて保存する。 
 
(2)アセンブリを作成する 
パーツを組み合わせた組図を作成する 
①[ファイル]>[新規作成]の順にクリックする。 
 
②[新規ファイル ]ダイアログボックスで、

Standard.iam をダブルクリックする。 
 
③アセンブリパネルから[コンポーネントを配置]
を選択し、先ほど作成したパーツを開いて配置

する。 
 
④アセンブリパネルを用いて、コンポーネント同

士に拘束条件などを付けて、組み合わせてい

く。 
 

⑤③～④を繰り返し、コンポーネントを組み合わ

せる。 
 
⑥出来上がったら、[ファイル]>[保存]を選択して

名前を付けて保存する。 

 
(3)シミュレーションソフトにインポートする 
HFSS や MW STUDIO に読み込ませて、電磁界

計算を行う場合には、[ファイル]>[コピーに名前

をつけて保存]を選択して、ファイルの種類に

[SAT ファイル]を選択して保存する。 
 
(4)加工図面を作成する 
設計して、実際作成するためには 2 次元の図面を

作成しなければならない。 
 
①[ファイル]>[新規作成]の順にクリックする。 
 
②[新規ファイル ]ダイアログボックスで、

Standard.idw をダブルクリックする。 
 
③図面ビューパネルから[ベースビュー]を選択

し、図面にしたいファイルを選択し尺度、方向

を決めて配置する。 
 
④さらに[図面ビューパネル]を利用し、投影図や

断面図、詳細図を加える。 
 
⑤[図面注記パネル]を利用し、寸法や公差などを

記入し図面を完成させる。 
 
⑥[ファイル]>[iproperty]で作成者やパーツ名、材

質、個数などを右下の表題欄を記入して、加工

図面を完成させる。 
 
⑦この作業を 1 つ 1 つの部品ごとに行い、部品図

面を作り、部品をくみ上げたときの組図も作成

すると、1 式の図面が完成する。 

3.3. 電磁波シミュレーション 

電磁界シミュレーションソフトとして主に HFSS
と MWSTUDIO などが使われている。ソフトに

よって解析方法に特徴があり、目的によって使い

分けたり、複数のソフトでシミュレーションを行

い、確認を行ったりすることが重要である。 



 ここでは空洞のシミュレーションを例に HFSS
と MW STUDIO の使い方を説明する。 

3.3.1. HFSS 

3.3.1.1. HFSS の概要 

HFSS には３つの解析方法があり、解析したいモ

デルの状況により適切に解析方法を選ぶ必要が

ある。 
 
Driven Modal： 
伝搬モードに着目した電磁界解析。導波管など

の解析に用いる。 
Driven Terminal： 

ノードに着目した電磁界解析。デジタル信号の

解析に用いる。 
Eigenmode： 
固有値解析。どんな電磁波が閉じ込めることが

できるかを調べる解析。 
 
この中で空洞の設計で用いられる Driven Modal
と Eigenmode の解析手順についてそれぞれ説明

する。 

3.3.1.2. Driven Modal での解析手順 

(1) プロジェクトの作成 
[File]>[New]をクリックして新しい Project を開

く。 
 
(2) 3D モデルの作成 
①シミュレーションモデルは Autodesk 社 

Inventor で作成し、ファイル形式を*.sat で保

存する。(HFSS で直接作成することも可能。) 
②[3D Modeler]>[Import…]をクリックすると

Import File 選択ダイアログが立ち上がる。 
③作成したモデルの sat ファイルを選択して[開
く]をクリックすると HFSS にモデルを読み込

む。 

 

Fig. 5 モデルのインポート 

(3) 単位の設定 
①[3D Modeler]>[Units]をクリックすると、Set 

Model Units ダイアログが立ち上がる。 
②Select units から単位(mm)を選択し、[OK]をク

リックする。 
 
(4) 材質の設定 
①[Edit]>[Select]>[ Objects]を選択する。 
②3D Modeler ダイアログで材質を決めたい

Object をクリックすると紫色に変わる。 

 

Fig. 6 材質の設定 

③[3DModeler]>[Assign Material]をクリックす

ると、Select Definition ダイアログボックスが

立ち上がる。 



 

Fig. 7 Select Definition ダイアログボックス 

④材質（vacuum）を選んで、[OK]をクリックす

る。 
 
(5) 境界条件の設定 
①[Edit]>[Select]>[ Face ]を選択する。 
②3D Modeler ダイアログで境界条件を決めたい

モデルの面をクリックすると紫色に変わる。 

 

Fig. 8 モデルの境界条件 

③[HFSS]>[Boundaries]>[Assign]>[境界条件(下
記の中より)]をクリックし境界条件を設定す

る。 

 

Fig. 9 境界条件の設定 

・Perfect E： 
完全導体、電界が境界面に対して垂直になる。

(デフォルト) 
・Perfect H： 
磁界が境界面に対して垂直になる。主に対象境

界時に使用。 
・Finite Conductivity： 
指定した導電率と透磁率を適用。 
クリック後 Finite Conductivity Boundary ダ

イアログでパラメーターを指定 
デフォルトで以下の状態では境界材質が銅で

ある。 
Conductivity; 5800000 
Relative Permittivity; 1 

 

Fig. 10 Finite Conductivity の設定 

Use Material で指定の材質に設定も可能である。  



 
・Impedance： 
波動インピーダンスを適用 

・Layered Impedance： 
表面の粗さ、メッキ処理 

・Radiation： 
電磁波をそのまま放射 

・Symmetry： 
対称境界条件、電磁波のふるまいが対象、

Perfect E、または Perfect H に設定 
・Master＆Slave： 

周期境界条件 
 
その他 PML(完全吸収境界)、Lumped RLC など

がある。 
※ポートと境界条件の重複はできない。 
 
(6) メッシュの設定 
通常は自動で行われるため、今回は特に設定する

必要はない。しかし、メッシュがさらに必要な場

合はマニュアルメッシュを設定する。 
 
①3D Modeler ウィンドウでメッシュを指定した

い面やオブジェクトをクリックする。 
②[HFSS]>[Mesh Operations]>[Assign]>[マニュ

アルメッシュの種類]をクリックする。 
On Selection： 
オブジェクト表面のメッシュを制御する。 

Inside Selection： 
オブジェクト内部のメッシュを制御する。 

③各々のマニュアルメッシュの設定をして[OK]
をクリックする。 

 
(7) Solution type の選択 
①[HFSS]>[Solution Type]をクリックすると

Solution Type ダイアログが開く。 
②以下の中から[Driven Modal]を選んで[OK]を

クリックする。 

 

Fig. 11 Solution type の選択 

(8) 解析の設定 
a. ポートを設定する。 
①[Edit]>[Select]>[ Face]を選択する。 
②3D Modeler ウィンドウでポートにしたいモデ

ルの面をクリックすると紫色に変わる。 

 

Fig. 12 ポートの設定 

③[HFSS]>[Excitations]>[Assign]>[Wave Port]
をクリックする。 
※port には Wave Port と Lumped Port がある

が、空洞設計には主に Wave Port を用いる。 
④Wave Port ダイアログが開き、port の設定を行

い、完了したら[OK]をクリックする。 



 

Fig. 13 ポートモードの設定 

Modes のタブにおいて 
 Number of Modes：1 
 解析を行いたいモードの数 
 (高次モードの解析を行う場合以外は通常 1) 
 Integration Line & 
 Characteristic Impedance：None , Zpi 
 S-parameter 算出時に使用 
 導波管を port にする場合は None＆Zpi 
 
 ※入射波源、入射波の種類などを指定すること

も可能である。 
 
b. Driven Modal 解析のセットアップ 
①[HFSS]>[Analysis Setup]>[Add Solution 

Setup]をクリックする。 
②Edit Sweep ダイアログの General のタブから

以下の設定を行う。 

 

Fig. 14 Setup の設定 

 Solution Frequency：1.3GHz 
 解析したい周波数付近の値を入れる。 
 Maximum Number of Passes：10 
 メッシュの粗さはここで決まり、数値が大きい

ほど精度が増す。 
③[OK]をクリックする。 
④[HFSS]>[Analysis Setup]>[Add Sweep]を選

択する。 
⑤Edit Sweep ダイアログで設定を行う。 

Sweep Type：必要に応じて[Discrete]にチェッ

クを入れる。[Discrete]を選ぶと、それぞれの

値において解析を行うため 3 つの中で精度が最

も良く、カットオフ周波数が周波数範囲にあっ

ても解析ができるが、解析時間はかかる。[Fast]
の場合は選択したポートのモードのカットオ

フに入らないように周波数の範囲を選ぶ。 
 
 Frequency Setup; 

 Type：[Linear Step] 
 Start・Stop：1.28GHz・1.32GHz 
 解析をしたい周波数の範囲 
 Step Size：0.001GHz 
 解析したい周波数間隔 

 



 フィールドを保存するには[Save Fields (All 
Frequency]にチェックを入れる 

 

Fig. 15 Sweep の設定 

⑥設定が終わったら[OK]をクリックする。 
⑦[HFSS]>[Analyze All]をクリックすると解析が

始まる。 
 
(9) Driven Modal での結果の見方 
a. ポートモードをみる 
Wave port から入射させたマイクロ波のモードを

確認する。 
左のウィンドウから[Port Field Display]>[Wave 
Port 名]>[Mode N]を選択する。 
 
b. S-parameter や Smith Chart をみる 
①[HFSS]>[Results]>[Create Report]をクリック

する。 
②Create Report ダイアログで Report Type と

Display Type を選ぶ。 
＊S-parameter の場合 
 Report Type：Modal Solution Data 
 Display Type：Rectangular Plot 

 

Fig. 16 Create Report ダイアログ 

次に Traces タブで以下のような設定をする。 
 Solution：解析した Setup 名 

(例 Setup1:sweep1) 
 Category： S Parameter 
 Quantity： 必要な S パラメーター 
 Function：単位(mag) 
 
設定できたら Add Trace をクリックして Done を

クリックする。 

 

Fig. 17 S-パラメーターの設定 



 

Fig. 18 S-パラメーター(結果) 

＊Smith Chart を見る 
 Report Type：Modal Solution Data 
 Display Type：Smith Chart 
 
次に Traces タブで以下のような設定をする。 
 Solution：解析した Setup 名 

(例 Setup1:sweep1) 
 Category：S Parameter 
 Quantity：必要な S パラメータ 
 Function：単位(None) 
 
設定できたら Add Trace をクリックして Done を

クリックする。 

 

Fig. 19 スミスチャート 

c. Field を見る 
①Filed を見たいオブジェクトまたは面をクリッ

クして、選択する。 
②[HFSS]>[Fields]>[ 見 た い Field(E 、 H な

ど)]>[Mag(強度)か Vector(ベクトル)]をクリッ

クすると、Create Field Plot ダイアログが開

く。 

 

Fig. 20 フィールドプロットの設定 

③Create Field Plot ダイアログで、見たいフィー

ルドの設定を行う。 
Solution：解析した Setup 名 

(例 Setup1:sweep1) 
 Intrinsic Variables； 
  Freq：周波数(例 1.307GHz) 
  Phase：位相(例 0deg) 
 
設定が終わったら[Done]をクリックすると、フィ

ールドが表示される。 

 

Fig. 21 共振周波数での磁場のベクトル分布 

d. フィールドの出力 
電場や磁場の各方向成分の分布をファイルに出

力することができる。 
①[HFSS]>[Field]>[Calculator]を選択すると、

Field Calculator ダイアログが開く。 



 

Fig. 22 出力するフィールドの選択 

②Field Calculator ダイアログで設定を行う。 
Context； 

Solution：出力したい Setup 名  
(例 Setup1:sweep1) 

Freq：周波数(例 1.307GHz) 
Phase：位相(例 0deg) 

 Input の Quantity で出力したいフィールドを

追加する。(例、E と H) 
 設定したら Output の Export をクリックする。 
 
③Export Solution ダイアログが開くので、以下

のような設定を行う。 

 

Fig. 23 出力するフィールドの設定 

 Output file name：出力するファイル名 
 Grid points on which to export： 

Calculate grid points にチェックを入れ 、
X,Y,Z についてフィールドデータがほしいグリ

ッ ド の 格 子 点 の Minimum( 最 小 値 ) と
Maximum(最大値)、Spacing(間隔)を入力する。 

設定が終わったら、[OK]をクリックする。 

3.3.1.3. Eigenmode での解析手順 

手順(1)～(6)までは Driven Modal での解析手順

と一緒である。詳しくは Driven Modal の解析手

順を参照。 
 
(1) プロジェクトの作成 

 
(2) 3D モデルの作成 

 

Fig. 24 Eigenmode シミュレーションモデル 



(3) 単位の設定 
[mm]を選択する。 

 
(4) 材質の設定 

Vacuum に設定する。 
 
(5) 境界条件の設定 

下図のような境界条件をとる。 

 

Fig. 25 境界条件の設定 

(6) メッシュの設定 
今回は特に設定を行う必要はない。 

 
(7) Solution type の選択 
①[HFSS]>[Solution Type]をクリックすると 
Solution Type ダイアログが開く。 

 

Fig. 26 Solution type の選択 

②以下の中から[Eigenmode]を選んで[OK]をク

リックする。 

 
(8) 解析の設定 
①[HFSS]>[Analysis Setup]>[Add Solution 

Setup]をクリックすると、Solution Setup ダイ

アログが立ち上がる。 

 

Fig. 27 Solution Setup ダイアログ 

General のタブから以下の設定を行う。 
 Minimum Frequency：1GHz 
 解析したい最低の周波数の値を入れる。 
 Number of Modes：5 
 探索させる共振モードの数。 
 Maximum Number of Passes：10 
 メッシュの粗さはここで決まり、数値が大きい

ほど精度が増す。 
 Maximum Delta Frequency Per Pass：0.1％ 
 計算の精度がここで決まり、数値を小さくする

ほどを精度が増す。 
②[OK]をクリックする。 
③[HFSS]>[Analyze All]をクリックすると解析が

始まる。 
 
(9) Eigenmode での結果の見方 
a. 共振モードの周波数を確認する。 
①[HFSS]>[Results]>[Solution Data]を選択する

と、Solutions ダイアログが開く。 
②[Eigenmode data]タブを選択するとそれぞれ

のモードの共振周波数が表示される。 



 

Fig. 28 Eigenmode data 

b. 各モードのフィールドを確認する。 
①フィールドを見たいオブジェクトまたは面を

クリックして、選択する。 
②[HFSS]>[Fields]>[ 見 た い Field(E 、 H な

ど)]>[Mag(強度)か Vector(ベクトル)]をクリッ

クする。 
③Create Filed Plot ダイアログが開くので、プロ

ットの設定を行い、[Done]をクリックする。 

 

Fig. 29 フィールドプロットの設定 

④左のウィンドウから[Field Overlays]を右クリ

ックして、[Edit Sources]をクリックすると、

Edit Sources ダイアログが開く。ここで、見た

いフィールドのモードの[Scaling Factor]を 1
にするとそのモードのフィールドの状態が表

示される。 

 

Fig. 30 モードの選択 

 

Fig. 31 Edit Sources ダイアログ 

 

Fig. 32 0 モードでの電場分布 



 

Fig. 33 π/2 モードでの電場分布 

 

Fig. 34 πモードでの電場分布 

3.3.2. MW-STUDIO 

3.3.2.1. MW-STUDIO の使い方 

MW STUDIO とは、高周波における電磁界シミ

ュレーションを行うソフトです。 
 このソフトには 4 つのシミュレーションソルバ

ーがあり、状況により適切に選ぶ必要がありま

す。 
・時間領域ソルバ： 

時間領域で計算してフーリエ変換により広帯

域周波数にわたる計算を行う。 
・周波数領域ソルバ： 
周波数ごとに計算を行う。 

・Eigenmode ソルバ： 
共振モードの計算を行う。 

・Integral Equation ソルバ： 
電気的に非常に大きな構造の場合に有効。 

3.3.2.2. 時間領域ソルバでの解析手順 

(1) CST DESIGN ENVIROMENT を起動し、

[Create a new project] か ら [CST 
MICROWAVE STUDIO]を選択し、[OK]をク

リックする。 

 

Fig. 35 プロジェクトの選択 

(2) プロジェクトテンプレートのダイアログが

開くので、シミュレーション対象のデバイス

に最も近いテンプレートを選択する。わから

ない場合は<None>を選択し[OK]をクリック

する。 



 

Fig. 36 テンプレートの選択 

(3) 単位の定義 
テンプレートを選択すると設定されるが変更す

る場合、[Solve]>[Units]を選択し、Units ダイア

ログに入力する。 

 

Fig. 37 単位の設定 

(4) 背景材質の定義 
テンプレートを選択すると設定されるが変更す

る場合、[Solve]>[Background Material]を選択

し、ダイアログボックスで背景材質を設定しま

す。 
＊背景材質として設定できるのは Vacuum と

PEC(完全導体)のみであるので Copper などにし

たい場合には、[Multiple layers]にチェックをし

て、物質と物質の層の高さを設定する。 

 

Fig. 38 背景材質の定義 

(5) モデルの作成 
①モデルの作成は Inventor で行い、*.sat ファイ

ル形式で保存する。 
※CST STUDIO で直接、モデルを作成するこ

とも可能。 
②[File]>[Import]>[SAT(up to R17)]を選択し、

Inventorで作成した satファイルをインポート

する。 



 

Fig. 39 モデルのインポート 

(6) 材質の定義 
左 の ナ ビ ゲ ー シ ョ ン ツ リ ー か ら

[Components]>[default]>[インポートしたファイ

ル]を右クリックして、[Change Material]をクリ

ックすると、ダイアログボックスが開き Material
で材質を選択する。 
材質は[Load from Material Library]から読み出

してくることができる。 

 

Fig. 40 材質の定義 

(7) 周波数範囲の設定 
[Solve]>[Frequency] を 選 択 し て 、 Frequency 
Range Setting ダイアログボックスで解析する最

低周波数と最高周波数を設定する。 

 

Fig. 41 周波数範囲の定義 

(8) 境界条件と対象条件の設定 
①[Solve]>[Boundary Conditions] を 選 択 し 、

Boundary Conditionsダイアログボックスで境

界条件を設定する。 
また、[symmetry planes]のタブから対称条件

を設定することもできる。 
②それぞれの面に対する境界条件を以下の中か

ら選択し、[OK]をクリックする。 
 electric：完全電気導体(Et=0) 
 magnetic：完全磁気導体(Ht=0) 
 open：自由空間 
 open(add space)：自由空間 
 遠方界計算のための余裕空間を追加。 
 periodic： 
 向かい合う 2 面の境界を周期的境界条件とす

る。 
 conducting wall： 
 損失のある金属材質の壁として動作 
 unit cell： 
 周期的境界条件、2 次元の周期性に加え、座標

軸の方向も定義できる。 

 

Fig. 42 境界条件の設定 



(9) メッシュの可視化 
[Mesh]>[Mesh View]を選択するとメッシュモー

ドとなり、メッシュが表示される。 
メッシュの面の方向は、 [Mesh]>[X/Y/Z Plane 
Normal]で変更し、メッシュ面を移動させるには

[Mesh]>[Increment/Decrement Index]を選択す

る。 

 

Fig. 43 メッシュビュー 

多くの場合、自動メッシュ生成機能が生成するメ

ッシュは初期メッシュとして妥当なメッシュで

あるが、表示されたメッシュを変更したい場合、

[Mesh]>[global Mesh Properties]を選択すると

変更させることができる。 
また、部分的に(特定のオブジェクトだけの)メッ

シュを変更したい場合には、左のナビゲーション

ツリーから[Components]>[default]>[メッシュの

変更したいオブジェクト]を右クリックして、

[local mesh property]をクリックすれば変更する

ことができる。 
 
(10) ポートの定義 
①[Object]>[Pick]>[Pick Face]をクリックして、

Face ピックツールを起動する。 
②ポートにしたい面をクリックして選択すると

選択された面はハイライト表示される。 

 

Fig. 44 ポートの定義 

③[Solve]>[Waveguide Ports]を選択すると Ports
ダイアログボックスが開く。 

 

Fig. 45 Port ダイアログ 

ここで設定を確認後、[OK]をクリックする。 
 
(11)  時間領域ソルバの設定 
[Solve]>[Transient Solver]を選択し時間領域ソ

ルバのダイアログボックスで設定を行う。 
 Accuracy： 
定常状態モニタを定義する設定。値を下げるほ

ど精度は良くなる。 
 Source Type： 
励振させたいポートを設定する。 



All Port はすべてのポートを 1 個ずつ励起、さ

せていく。 
 Mode：励振させるモードの数 
 S-parameter setting： 

自動的に計算、正規化したい場合、[Normalize 
to fixed impedance]を選択する。 

 

Fig. 46 時間領域ソルバの設定 

設定が終わったら、[Start]をクリックし、シミュ

レーションが開始する。 
 
(12) ポートモードの解析 
ナ ビ ゲ ー シ ョ ン ツ リ ー か ら [2D/3D 
Results]>[Port Modes]>[ポート名]>[見たいモー

ドと電界か地場か(e1 や h1 など)]を選択すると、

ポートモードとそれに関連したパラメーターが

表示される。 
こ の 表 示 を 調 整 す る に は [Results]>[Plot 
Properties]を選択してプロットプロパティダイ

アログを開いてプロットオプションを変更させ

る。 
 
(13) S-パラメーターの解析 
シミュレーションが終了したら、ナビゲーション

ツリーの[1D Results]>[Port signals]を選択し、

ポートモードの時間信号を確認する。 
ここでシミュレーション終了前にすべての時間

信号が 0 まで減衰していることが重要である。 

 
S-パラメーターを表示させるには、ナビゲーショ

ンツリーの[1D Results]>[|S| linear]/[|S| dB]
を選択することにより表示される。 

 

Fig. 47 S-parameter 

また、スミスチャートも [1D Results]>[Smith 
Chart]を選択することにより表示される。 

 

Fig. 48 スミスチャート 

(14) 適応メッシュリファイン 
ソルバ結果を基に改善し、メッシュを適応させる

適応メッシュリファイン機能を備えている。 
この機能は Solver Parameters ダイアログで

[Adaptive mesh refinement]をチェックすると有

効になる。 
[Start]をクリックすると、ソルバは連続したパス

間で S-パラメーターが大きく変異しないように

なるまでメッシュリファインのパスを実行しま

す。このパスが実行され、終了すると以下のよう



なダイアログボックスが表示され、メッシュがリ

ファインできる。 
ここで[Yes]をクリックしてメッシュ適応機能を

オフにして、再度解析をしてもメッシュは有効と

なっている。 

 

Fig. 49 適応メッシュリファイン 

(15) 複数の周波数での電磁界解析 
[Solve]>[Field Monitors]でモニタを定義するこ

とで、シミュレーション中に任意の周波数におけ

る電磁界を記録することができる。 
Monitor のダイアログで、モニタの種類(Type)と
Frequency フィールドで周波数を指定し、[Apply]
をクリックし設定を保存する。 

 

Fig. 50 モニタの設定 

記録した電磁界分布を表示させるには、ナビゲー

ションツリーの [2D/3D Results]>[E-field] or 
[H-field]>[表示させたいフィールド]を選択する。 
[Results]>[Plot Properties]から3Dベクトルプロ

ットのオプションを変更することによりいろい

ろと表示することがでる。  
また、構造の断面表示は[Results]>[3D Fields on 
2D Plane]を選択することにより表示ができる。 

 

Fig. 51 磁場分布 

(16) 周波数領域ソルバでのシミュレーション 
時間領域ソルバは高速に計算を行うが、周波数領

域ソルバは周波数のサンプルポイントごとに計

算を行うため非常に時間がかかる。しかし、MW 
STUDIO の周波数ソルバは特殊な広帯域周波数

スイープ技術を用いて、比較的少ない周波数サン

プルから広帯域スペクトルを導き出すことがで

きる。 
 
[Solve]>[Frequency Domain Solver]を選択し、

Frequency Domain Solver Parameter ダイアロ 
グで設定を行う。 
 Method：General purpose 
 （一般的なソルバ、他は対象を特化したソル

バ） 
 Mesh type：Tetrahedral Mesh 
 （四面体メッシュ） 
スイープ技術を用いるには Frequency Samples
で Frequency 行の[Auto]にチェックを入れ、周波



数ポイントの自動サンプリングを有効にした後、

[Use broadband frequency sweep]にチェックを

入れる。 
これで[Start]をクリックすると、解析が開始され

る。 

 

Fig. 52 周波数領域ソルバの設定 

3.3.2.3. Eigenmode ソルバでの解析手順 

手順(1)～(9)までは時間領域ソルバでの解析手順

と一緒である。詳しくは時間領域ソルバの解析手

順を参照。 
(1) 新しいプロジェクトを開く。 
 
(2) テンプレートを選択する。 
 
(3) 単位を定義する。 
 Dimensions：mm 
 Frequency： GHz 
 
(4) 背景材質を定義する。 
 PIC とする。 
 
(5) モデルをインポートする。 

 

Fig. 53 Eigenmode モデル 

(6) 材質の定義 
  Vacuum とする。 
 
(7) 周波数範囲の設定 
  1.2GHz～3.5GHz とする。 
 
(8) 境界条件と対象条件の設定 

 

Fig. 54 境界・対象条件の定義 



(9) メッシュの可視化 

 

Fig. 55 メッシュの確認 

(10) Eigenmode ソルバの設定 
固有モードソルバは、閉じたデバイスの有限個の

電磁界共振モード分布を計算する。そのため、ポ

ートの定義は必要ない。 
 
固有モードで計算するには[Solve]>[Eigenmode 
Solver]で Eigenmode Solver Parameters ダイア

ログで設定を行う。 
 Solver setting； 
 Method： 
モードの数に応じて、適切なソルバメソッドを

選択する。 
 ・損失がある問題⇒JDM 
 ・損失がない問題＋モードの数(1～5)⇒JDM 
 ・損失がない問題＋モードの数(5 以上)⇒AKS 
 Mode：必要なモードの数を入力する。 

 

Fig. 56 Eigenmode の設定 

設定が完了したら、[Start]をクリックすると、解

析が開始する。 
 
(11) 結果の見方 
固有モードソルバの N 次モードの結果はナビゲ

ーションツリーからアクセスすることができる。 

Table 1 結果の表示 

Navigation tree Type of results 

[2D/3D Results] > [Mode] 
> [Mode N] > [e] Electric field 

[2D/3D Results] > [Mode] 
> [Mode N] > [h] Magnetic field 

[2D/3D Results] > [Mode] 
> [ModeN] > [Surface 

Current] 

Surface current 
field 

[2D/3D Results] > [Mode] 
> [Mode N] > [Energy 

density] 
Energy density



 

Fig. 57 0 モードの電場分布 

 

Fig. 58 πモードの電場分布 
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